xF1 Unmaintained - Defer JS | NulledTeam UnderGround | The Best Scripts Site In The World
Defer JS

xF1 Unmaintained Defer JS 2.2.4

No permission to download
Compatible XF Versions 1.x
1.4, 1.5
Additional Requirements
PHP 5.4+
This add-on collects javascripts in post-view output and moves them to the bottom of the page. This has a noticeable impact on page-load times as pending HTTP requests postpone rendering of a page, while scripts aren't run anyways until everything is loaded.

This add-on requires PHP 5.4+!
Trying to install it on earlier versions will break your forum.


Much of the heavy lifting was derived (with permission) from @luke Foreman's XFOptimise add-on, which is no longer maintained.

This add-on is open-source under the MIT license and the source may be found at jrahmy/DeferJs · GitHub
Author
AnimeHaxor
Downloads
50
Views
571
First release
Last update
Rating
5.00 star(s) 1 ratings

More resources from AnimeHaxor

Latest updates

  1. Fix for loading attachments into memory

    This fixes a bug where attachments were loaded into memory to check for HTML content. This could...

Latest reviews

i like this addon

AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock