s3ker

Registered
Joined
6 year 4 month 23 day
Messages
10
Reaction score
1
Points
3
Age
29
Location
EGYPT
hello

please any one can help me ?!!

when i try to upgrade xenforo 2.2.2 to 2.2.3 patch level 1

and i stopped addons
my site it start to upgrade and stop in this step
https//:xxxx.com/install/index.php?upgrade/run-job
xxxx it is my name site
when my upgrade arrive to finish this step
Importing... Master data (Templates 39)
this code of error

HTML:
ErrorException: [E_WARNING] file_put_contents(/home/mrsat8iy/public_html/internal_data/code_cache/templates/l0/s1/public/setup_custom.less.php): failed to open stream: Permission denied in src/vendor/league/flysystem/src/Adapter/Local.php at line 199
XF::handlePhpError()
file_put_contents() in src/vendor/league/flysystem/src/Adapter/Local.php at line 199
League\Flysystem\Adapter\Local->update() in src/vendor/league/flysystem/src/Filesystem.php at line 99
League\Flysystem\Filesystem->put()
call_user_func_array() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 431
League\Flysystem\EventableFilesystem\EventableFilesystem->callFilesystemMethod() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 395
League\Flysystem\EventableFilesystem\EventableFilesystem->delegateMethodCall() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 57
League\Flysystem\EventableFilesystem\EventableFilesystem->put() in src/vendor/league/flysystem/src/MountManager.php at line 597
League\Flysystem\MountManager->put() in src/XF/Util/File.php at line 197
XF\Util\File::writeToAbstractedPath() in src/XF/Service/Template/Compile.php at line 146
XF\Service\Template\Compile->writeCompiled() in src/XF/Service/Template/Compile.php at line 43
XF\Service\Template\Compile->recompile() in src/XF/Entity/Template.php at line 433
XF\Entity\Template->_postSave() in src/XF/Mvc/Entity/Entity.php at line 1266
XF\Mvc\Entity\Entity->save() in src/XF/AddOn/DataType/Template.php at line 97
XF\AddOn\DataType\Template->importAddOnData() in src/XF/Job/AddOnData.php at line 110
XF\Job\AddOnData->run() in src/XF/Job/Atomic.php at line 38
XF\Job\Atomic->run() in src/XF/Job/Manager.php at line 258
XF\Job\Manager->runJobInternal() in src/XF/Job/Manager.php at line 200
XF\Job\Manager->runJobEntry() in src/XF/Job/Manager.php at line 151
XF\Job\Manager->runUnique() in src/XF/Install/Controller/AbstractController.php at line 24
XF\Install\Controller\AbstractController->manualJobRunner() in src/XF/Install/Controller/Upgrade.php at line 262
XF\Install\Controller\Upgrade->actionRunJob() in src/XF/Mvc/Dispatcher.php at line 350
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 257
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 113
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 55
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2326
XF\App->run() in src/XF.php at line 488
XF::runApp() in install/index.php at line 14

and this screen shoot

image82.html



and it is big problem because my site it is of now for complete upgrade

Please help me
 

Admin

Staff member
Administrator
Registered
Joined
8 year 7 month 27 day
Messages
15,966
Reaction score
55,214
Points
113
Age
50
Site Script
XenForo
Helo

If you receive this message, open your FTP client and navigate to your XenForo root directory (the directory your created earlier). You should see the data and internal_data directories. You will need to change permissions on these two directories.

In Linux, these should be "chmod 0777".
 

s3ker

Registered
Joined
6 year 4 month 23 day
Messages
10
Reaction score
1
Points
3
Age
29
Location
EGYPT
Helo

If you receive this message, open your FTP client and navigate to your XenForo root directory (the directory your created earlier). You should see the data and internal_data directories. You will need to change permissions on these two directories.

In Linux, these should be "chmod 0777".
thanks Boss .. i do it and it sill the same error
 

s3ker

Registered
Joined
6 year 4 month 23 day
Messages
10
Reaction score
1
Points
3
Age
29
Location
EGYPT
I Have back files to Xenforo 2.2.2 and my site back to life
but when i try to make /admin.php?tools/run-job
the same error
i do not know the Reason ?!!!

please any one can help me i need to fix
 

s3ker

Registered
Joined
6 year 4 month 23 day
Messages
10
Reaction score
1
Points
3
Age
29
Location
EGYPT
I Have fixed
by this way

when i looking for permission file i found it take 0000
but when i change permission to 0644
the problem it fixed
thanks nulledteam Society